[vox-if] Installfest Hardware, etc.

Christopher James McKenzie mckenzie at cs.ucdavis.edu
Tue Mar 18 15:21:15 PDT 2008

javilk at mall-net.com wrote:
>> javilk at mall-net.com wrote:
>>>      I am considering coming to the installfest.  I've been running 
>>> Linux for 12 years, etc. etc.  No Windows in this house!  But I'm an 
>>> applications programmer, not a systems administrator.
>     A little bit late now...

Look out for April 13th...

>     Ubuntu... I run three root sessions, two webmaster sessions, and 
> four or more login sessions on consoles (plus two to five gooey web 
> browser sessions) when I'm working.  I hear Ubuntu does not like root 
> sessions... Anyone who does not allow the user to fry his own machine is 
> a crook!  It's how we learn...

Well, it sounds like you know what you are doing.  In as such, I don't 
know whether you'd experience a substantial gain from the large support 

And no, I believe you are incorrect in your statement regarding Ubuntu 
being inadequate.  Well, Ubuntu takes a little bit of encouragement, but 
not a lot to achieve what you speak of.

>     Ah!  Didn't think of that. Like I say, I'm an applications guy. (She 
> is my sys, and I admin her, but...) Actually, I think it can... And I do 
> have other machines... (I'm on solar, so the real machines require a 
> running generator.  Really crimps my style, but I could run it for an 
> hour or so. Or wait till I get down to the warehouse this weekend.  My 
> real machines run in the warehouse, this notebook is just a low power 
> terminal to them.)
>      How could I set that up?

There are a number of protocols for ethernet booting.  Mostly they 
involve the card sending out a broadcast request, then a booting server 
contacting the mac address and servicing the loader.  However, your card 
has to natively support it.  You can check the bios.

If this doesn't work, I believe some PC-Cards support this, but I need 
to look into it.

>       I tried that. It produces a catatonic machine because all the 
> custom I/O chips, etc. won't let me talk to the peripherals.  Done this 
> on several notebooks, I just can't seem to get that to work.  The other 

It's because your install wasn't minimal enough.  You need to install it 
on machine X, then strip the kernel of all the special affordings that 
machine X uses, such as ACPI, Pentium 4 instruction set for a kernel, 
etc, down to a base kernel that will basically load an 80x25 screen and 
a bash shell.

Then from there you do a custom compile of the kernel on the destination 

> method... seems you can't stick (or I don't know how to stick) a boot 
> sector on a USB mounted drive... I tried.  Won't boot when the drive is 
> put inside the notebook.

This is certainly BIOS specific - like the ethernet booting.  Depending 
on how ridiculous your BIOS decided to be, you may also be able to boot 
over FIR, serial, or firewire.  I agree that doing an install over FIR 
would be one of the most proposterous things I've done at the 
installfests in 8 years, but I've seen the option, and I suppose I could 
figure out how to tunnel files over it.

>      I can mount the rest of the "cluster" (a group of five to twelve 
> NFS coupled machines using a common queue to run tasks); but the rest of 

Don't cluster with NFS, just don't... use something modern like CODA or 
OpenAFS, you'll see significant performance gains, I promise.

> the cluster can't mount any of it's drives.  (And right now, that 
> machine is down.  A migration script moved /bin and /sbin ... I'll have 
> to drive down to the office some night soon to put them back where they 
> should be... The joys of doing things remotely as Root.  The first time 
> this happened, I was able to deduce where those were and put them back 
> before the session link was interrupted. This time, mv won't execute.  
> Ah well, life in the fast lane.  That's what rescue CD's are for.)

So you just have NFS on a NAS?  Have you LVM'd over the NFS mounts?  I'm 
sorry, I still don't get the exact problem here.

>       And a whole bunch of other issues with no TCPIP on the Novell 
> demo, inadequate tag queue depth in the Fedora version... etc.  If I saw 
> these guys had a GOOD WORKING version, I'd toss them the cash!

Are you talking about SUSE?  Really, most of the commercial linuxes are 
inadequate for various reasons.

>       I know I really ought to compile my own... but then I'd really get

Compile your own what? Sorry, I don't understand. If you are doing 
clustering, there are quite a few distros slated for this exact purpose.

> lost!  The only thing I'd really like to do that would be worth while, 
> is fixing the absurd variable processing in BASH.  

You don't need to use BASH. There is no lack of languages out there. 
Especially ones that can do reflection with variable names.  PHP, Ruby, 
Python, etc...

More information about the vox-if mailing list